All systems operational

Client Portal is DOWN

Resolved
Major outage
Started 10 months ago Lasted 6 minutes

Affected

Essentials
Client Portal + API
Updates
  • Resolved
    Resolved

    [Auto Monitor] Client Portal Recovered. This incident has been resolved.

  • Investigating
    Investigating

    [Auto Monitor] Client Portal is now down.